1. Choose your language
  2. License agreements
  3. System compatibility
  4. Store information
  5. System configuration
  6. Store installation

Installation Assistant

  • Choose your language
  • License agreements
  • System compatibility
  • Store information
  • System configuration
  • Store installation

We are currently checking PrestaShop compatibility with your system environment

If you have any questions, please visit our documentation and community forum.

PrestaShop compatibility with your system environment has been verified!

  • Required PHP parameters
  • PHP 5.4 or later is not enabled
  • Cannot upload files
  • Cannot create new files and folders
  • cURL extension is not enabled
  • GD library is not installed
  • JSON extension is not loaded
  • PHP OpenSSL extension is not loaded
  • PDO MySQL extension is not loaded
  • SimpleXML extension is not loaded
  • ZIP extension is not enabled
  • Fileinfo extension is not enabled
  • Cannot open external URLs (requires allow_url_fopen as On)
  • Required Apache configuration
  • Enable the Apache mod_rewrite module
  • Files
  • Not all files were successfully uploaded on your server
  • Permissions on files and folders
  • Recursive write permissions for Apache user on ~/config/
  • Recursive write permissions for Apache user on ~/app/cache/
  • Recursive write permissions for Apache user on ~/app/logs/
  • Recursive write permissions for Apache user on ~/img/
  • Recursive write permissions for Apache user on ~/mails/
  • Recursive write permissions for Apache user on ~/modules/
  • Recursive write permissions for Apache user on ~/themes/classic/lang/
  • Recursive write permissions for Apache user on ~/themes/classic/pdf/lang/
  • Recursive write permissions for Apache user on ~/themes/classic/cache/
  • Recursive write permissions for Apache user on ~/translations/
  • Recursive write permissions for Apache user on ~/upload/
  • Recursive write permissions for Apache user on ~/download/
  • Write permissions for Apache user on ~/app/config/
  • Write permissions for Apache user on ~/app/Resources/translations/
  • Recommended PHP parameters
  • GZIP compression is not activated
  • Mbstring extension is not enabled
  • Dom extension is not loaded
  • Install and/or enable a PHP accelerator (highly recommended).
  • Set short_open_tag to off in php.ini*.

If you need some assistance, you can get tailored help from our support team. The official documentation is also here to guide you.